Bug to buy PRV from USDC in Incognito app

Hi,

I am trying to buy PRV using USDC but there is a bug in the Trade pane in Incognito app.

If the amount can be written in 3 lines, the “Confirm” button appears in the bottom:

good

If the amount occupies 4 lines, the button doesn’t show and it is not possible to scroll down:

bad

Maybe you should limit the decimal places shown to avoid that problem. As the text says “Buy at least”, you can just truncate since it will still be a true statement.

4 Likes

Maybe as a work around set the size of the phone fonts smaller. That might make it so there is only 3 lines.

2 Likes

Being able to scroll would be best. Did you try to change the decimal setting in settings? Just wondering if that would solve it for now.

1 Like

Hi, @fitz_fiat, I had not thought about that “hack”.

Hi, @Jamie, didn’t know about the decimal digits limit in settings, but it is “On”.

Since the transaction fee is very low, I made two separate transactions and I am ok for now. Anyway, the limit should have been respected, imo.

2 Likes

That is also a way to fix it. It will be solved either by adjusting the font, limiting the digits, or scrolling. And maybe even all. Thanks for bringing it to our attention.

Hi Jamie,

I’ve had this issue in the past too, with my app on the phone not being able to place PRV trades due to the scroll lock. I got around using the app on my ipad, but it would help if we could get this fixed in the upcoming updates.

1 Like

It is in the works.

When we say “thanks for bringing it to our attention” it means we have notified the devs and it has been added to the bug list.

Fingers crossed it will be solved in the next update.

2 Likes

Would you mind sharing what device you are using and the screen size of that device? It will help us troubleshoot and solve the issue.

1 Like

Motorola Moto G5 Plus:

Display
5.2 inches
1920 x 1080 pixels

1 Like

Could you try to restart the app? You should be able to scroll.

Unfortunately I have already made the transactions and with the funds I have now there is no need for scroll, so I can’t test it, sorry.

1 Like

Don’t worry about it. If it happens again, please update this post.

1 Like

It turns out it was a bug fixed and then unfortunately it made its way back into the code. Will be fixed again in the upcoming release.