bootstraping for shard0 leads to shard stall

Hello. I’m using version 1.5 to get shard 0, but it always end up with shard stall. Maybe the bootstrap file is corrupted?

I have already tried 3 times.

Try stopping the container, deleting out the other files (not block directory) and starting it again.

Like deleting the entire shard0 directory?

Higher up than that. Delete the node files except for mainnet/block directory.

I have deleted the shard0 directory and the node correctly starts syncing. I don’t think it a node problem. Even knowing that you suggest deleting its files?

Well, I tried what you suggested and it’s still stalling.

I tried to let it sync by itself 3 times already, but it always gets stuck at around 63902. I tried deleting all its files and the docker container itself without success.

What else can I try?

Please use memtester to check your nodes RAM. Constant stalling would indicate a memory issue.

I have 30 GB of ram, and currently only 6.5 GB are being used.

I ran a test for 20 GB of ram and it went clean.

pagesize is 4096
pagesizemask is 0xfffffffffffff000
want 20480MB (21474836480 bytes)
got  20480MB (21474836480 bytes), trying mlock ...locked.
Loop 1/2:
  Stuck Address       : ok         
  Random Value        : ok
  Compare XOR         : ok
  Compare SUB         : ok
  Compare MUL         : ok
  Compare DIV         : ok
  Compare OR          : ok
  Compare AND         : ok
  Sequential Increment: ok
  Solid Bits          : ok         
  Block Sequential    : ok         
  Checkerboard        : ok         
  Bit Spread          : ok         
  Bit Flip            : ok          
  Walking Ones        : ok         
  Walking Zeroes      : ok         
  8-bit Writes        : ok
  16-bit Writes       : ok

Sorry for the delay. I am testing the bootstrap for shard0 on one of my nodes.

1 Like

Bootstrapping now. Just to confirm you were using option 0 and not 00, correct?


1 Like

Bootstrap has finished completely. Please PM me and we can do a remote session.