Advanced set up: customize the port of your Node

Yep this seems to be correct. I’ve not had the time to work on the app but I’m hoping to do some changes to the ‘status’ field so it lets you know that the node is syncing among other things. I’m hoping to be able to get back to this in the next few days.

1 Like

is it a correct return after running

rpc_port=9334 node_port=9433 ./

-bash: ./ Permission denied


Try running chmod +x ./ to add execution permissions

before doing running rpc_port=9334 node_port=9433 ./

rpc_port=9334 node_port=9433 ./

/bin/sh: 0: Can't open bash

@mesquka is this editing correct?

Yep, before running rpc_port=9334 node_port=9433 ./

@huglester, so you following method #2 in this post? Advanced set up: customize the port of your Node
if you tail -f the log file you may notice that when your node sync/insert new block, it sometime require Ethereum block to verify deposit proof (Eg. from ETH to pETH in Incognito-chain)

1 Like


Ok I will test and get back to you.
For now will keep an eye on logs to make sure i do not break anything

parity light - does not show rpc connections

Apr 17 12:12:56 xxx parity[24356]: 2020-04-17 12:12:56 Syncing #9889294 0x16c0…a5f8 0.1 hdr/s 0+ 0 Qed 49/64 peers 10 MiB cache 0 bytes queue RPC: 0 conn, 0 req/s, 822 µs

Please maybe show me example strings- for which I should search so I know it actually works :slight_smile:

I checked nginx proxy (I run parity behind proxy) - but I dont see anyone connecting to node in logs :frowning:


@huglester, i thought you try infura. To double check, can you show me the line of code in your that trigger docker container?

If you running parity light, check this command docker logs -f eth_mainnet
In short, the inc_mainnet container will connect to eth_mainnet container to get ETH block data.

1 Like

its same as INFURA. Just different link. I can try infura - but believe result will be the same. since infura also is http://… some link.

my startup is:

; this acts like infura - I can send curl commands to it and get response
; could be like:

docker run --restart=always --net inc_net -p $node_port_temp:$node_port_temp -p $rpc_port_temp:$rpc_port_temp -e NODE_PORT=$node_port_temp -e RPC_PORT=$rpc_port_temp -e BOOTNODE_IP=$bootnode -e GETH_NAME=$GETH_TMP -e MININGKEY=${validator_key} -e TESTNET=false -v $PWD/${data_dir}:/data -d --name inc_mainnet${index} incognitochain/incognito-mainnet:${latest_tag} 

well I do not want to use parity light on same host. I wanna run it externally. is that possible?

@khanhj just tagging you. wanna make sure my nodes are “OK” :slight_smile:


Your setup with external GETH should work, make sure you add these params to docker run command


You can take a look at the default for reference

1 Like


-e BOOTNODE_IP=$bootnode -e -e GETH_PROTOCOL=https -e GETH_PORT= -e MININGKEY=xxx

is that ok? infura shows 0 requests…

which - has no example of GETH_PORT/PROTOCOL
github - also does not have

thanks @khanhj

@duc can you please advise?


I also tried doing like so:

# docker exec -it inc_mainnet sh
/ # cd /
/ # grep -i GETH *.sh
/ #

as you can see no signs of GETH variable in docker *.sh files

I also see now in infura some request.

also logs give this:

cat data/log.txt | grep 'eth_'| more
 -1002: Method not found: eth_getBlockByNumber
2020-04-18 17:17:30.024 request.go:49 [ERR] RPC log: Can not parse [{"jsonrpc":"2.0","id":0,"method":"eth_accounts"}]

not sure how good is that

i think your config is correct, do you see any request to infura now?
I’m checking with the team to see how to properly see ETH log…